JavaScript is required to use Bungie.net

Help

Help us help you.
Edited by NoPantsoN: 7/8/2019 4:22:10 AM
24

Battlenet says the game is running but its not.

I installed a new mobo and cpu today. Gigabyte x570 and Ryzen 3700x. Destiny2 ran fine as of last night on the intel setup. I have re-installed the video driver as a fresh install. Uninstalled and re-installed destiny 2. Have all of the updated drivers possible for the board. When i click play on battlenet it says its launching the game. Battlenet minimizes and the game never comes up. It will show up in task manager and stay there for a minute or 2 then its just gone. Battlenet will say at that time that the game is still running. Specs. Ryzen 7 3700x Gigabyte Aorous x570 Gigabyte 1080ti 32gb Evga ddr4 3200 Another thread same issue. https://www.bungie.net/en/Forums/Post/252737886 **Edit** Added Picture
English
#Help #pcsupport

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • My System is running a Ryzen 5 1400 and the game launcher will not even run. So, I suspect that anyone with an AMD processor is more than likely not able to run this game. Sad.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Same issue today and like everybody else, installed a new 3700X today

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    1 Reply
    • Same issue here, running on a 3700x. Comment to bump, I guess

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    • Same issue, no problems when i had a 2700X in but I put my 3800X and no destiny 2. Please address this bungie!!!!

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

      1 Reply
      • Hi there. We're currently investigating this issue.

        Posting in language:

         

        Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        11 Replies
        • 3900x Gigabyte X570 Ultra Vega 64 Same problem.

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        • Seems I too currently have the same fate as many other early Ryzen 3000 series adopters. I have a 3600X in a ASUS RoG Strix X 470-F motherboard that runs great (and actually hits its max boost clock!! ), sadly it will NOT run Destiny 2 and that is my main game. Everything else I have thrown at it from Divinity II Original Sin, Witcher 3, Metro Exodus, Apex Legends and The Division 2 all run perfectly. Hopefully this gets rectified soon as I am trying to finish out Bad JuJu questline and only have a small amount of time to play due to hectic work schedule

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        • Glad Im not the only one having issues. upgraded to a ryzen 3700x today

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        • Edited by Travis1337: 7/8/2019 3:58:46 AM
          Literally everything else works great on my new 3600 except for destiny 2 which wont even try to load. Bump as same issue except my destiny 2 process doesnt disappear from task manager it stays until i end task also just want to add i'm on the asus x470-f board if it helps

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

          1 Reply
          • Edited by Zushi: 7/10/2019 1:31:48 PM
            Me too. I also had this issue with CS:GO and Half-Life some years ago. But after an update these games worked again for me. These days I only play Counter Strike for skin gambling. I found an interesting article about it on [url=https://www.counterstrikebetting.com/skin-gambling/]www.counterstrikebetting.com[/url].

            Posting in language:

             

            Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

          • Same here. Same issue but no solution yet. Adding myself to the train to follow.

            Posting in language:

             

            Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

            2 Replies
            • I too am having exact issue. I am running a Ryzen 3600X on a Asrock X470 Taichi. I also got a Radeon 5700. I click on Play and it says "game is running" never loads. It also as well shows in the Task manager. This in on a fres Windows 10 install of a usb stick. I d/l windows 10 from Microsofts website. No shady copies here.

              Posting in language:

               

              Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

              1 Reply
              • Destiny 2 will also not launch when Ryzen 3K CPUs are installed on X470 boards FYI. I'm on an ROG Strix X470I with the latest BIOS- 06/21 release with AGESA combo 1.0.0.2 , the application will not launch. no other apps are affected.

                Posting in language:

                 

                Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

              • [quote]I installed a new mobo and cpu today. Gigabyte x570 and Ryzen 3700x. Destiny2 ran fine as of last night on the intel setup. I have re-installed the video driver as a fresh install. Uninstalled and re-installed destiny 2. Have all of the updated drivers possible for the board. When i click play on battlenet it says its launching the game. Battlenet minimizes and the game never comes up. It will show up in task manager and stay there for a minute or 2 then its just gone. Battlenet will say at that time that the game is still running. Specs. Ryzen 7 3700x Gigabyte Aorous x570 Gigabyte 1080ti 32gb Evga ddr4 3200 **Edit** Added Picture[/quote] Adding myself to the thread

                Posting in language:

                 

                Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                1 Reply
                • Yup, got a new motherboard and the 3900X and can't launch it. Did everything in every post and thread I could get my hands on - even reinstalled the launcher AND the game. No dice. This is honestly laughable - except for how infuriating it is that I can't play the game I bought.

                  Posting in language:

                   

                  Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  11 Replies
                  • Edited by twopoint7: 7/8/2019 4:30:40 PM
                    deleted

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  • Same here. CH7 Hero X470 and 3900X.

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  • Same issue. 3900x on Aorus Master x570

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  • Same issue for me [u]Setup:[/u] MB: Gigabyte Aorus Master X570 CPU: 3700x GPU: GTX 1080ti

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  • Edited by Pickles: 7/8/2019 4:14:18 AM
                    I made a post here: https://www.bungie.net/en/Forums/Post/252737886?sort=0&page=0 Describes exact symptoms: Symptoms: When you launch Destiny 2 from Battlenet, it will say it is launched but nothing happens. Upon looking at task manager, Destiny 2 will stay inside of Battlenet process, use about 10-17% cpu, about 158.2MBs then after abotu 5-10 minutes reduce to 128MB. No network usage, no disk usage. Just hangs.

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  • Same here Asus crosshair viii hero 3900x So lame I reinstalled windows 3 times trying do fix it

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  • Same here. Ryzen 3600 Gigabyte ab350 EVGA 1080 16gb EVGA ddr4 3200

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  • I'm having the exact same problem after upgrading to a Ryzen 3700x today. Sorry, I still haven't found a solution yet, but makes me feel a little better I'm not the only one.

                    Posting in language:

                     

                    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                    2 Replies
                    • commenting to follow the thread as I am having the same issues. 3700x Asus Rog Strix -E x570 Evga 1080ti 16gb hyper x ram

                      Posting in language:

                       

                      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                    You are not allowed to view this content.
                    ;
                    preload icon
                    preload icon
                    preload icon