JavaScript is required to use Bungie.net

Help

Help us help you.
Edited by postal268: 11/10/2017 1:33:23 AM
11

[Solved] Game will not launch windows 7 x64

I wanted to buy a second copy of the game for my wife, but after installing destiny 2 on her computer and attempting to open it (So I could test performance) it would not open. Configuration Info CPU: AMD FX-8350 4.01GHz GPU: ATI RADEON HD6950 2gb VRAM RAM: 8GB GPU Driver Version: Radeon 16.2.1 Operating System: Windows 7 Ultimate x64 DxDiag: https://www.dropbox.com/s/qycq8tjucjyjh7t/DxDiag.txt?dl=0 Issue Information Destination/Activity: Launching the game Description: I click the play button on the launcher, the button grays out, and it tells me the game is open. After a minute the Play button comes back. The game never opens. I was able to get the game to open and run one time by cutting and pasting the file GFSDK_Aftermath_lib.dll to the Destiny 2 main folder, but that trick only worked one time.

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Also having this issue, version 4186578. Didn't play yesterday but it was working for me on Wednesday, Nov 8 this week. Tried everything in this other post: https://www.bungie.net/en/Forums/Post/238048509?sort=0&page=0 but to no avail. This sucks.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    1 Reply
    • Edited by postal268: 11/10/2017 1:33:48 AM
      SOLUTION Ok so I received this as a PM and it has worked for me two times so far, so I am going to label this as the solution. "Hey man, so I got my game to work. I didnt use anything from the forum you suggested, but what i did was have Blizzard Battlenet Application closed. Right click and "Run As Admin" from the desktop shortcut. This does not start the game but open the Battlenet Application. From there i clicked Play and the game opened up. I tried to open the game up a few times after it worked and everything came up. Even without running as admin. I hope this helps you" Apparently I have to run the game launcher as Admin with battlenet closed instead of opening battlenet and then selecting to open the game. So use game launcher to launch battlenet instead of vice versa.

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    • Bump

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

      1 Reply
      • Would settings from one computer carry over to the next? If so, would this cause issues? My resolution on the other pc is setup for triple monitors so would that perhaps cause an issue here? Just an idea.

        Posting in language:

         

        Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        10 Replies
        • Edited by Doovle: 11/8/2017 2:11:07 PM
          Try running Catalyst Driver 15.11.1 , Omega or the newer ones do not support your card. 16.2.1 is no CL support for that video card. Since you are running a unsupported video card or legacy. I recommend you go with the 15.11.1 or Driver Packaging Version 15.201.1151.1010-151118a-296614E Which is the last Version of software to support full CL for that video card. I do not recommend updating further. If you wish to upgrade further grab the drivers from that package and overwrite new package drivers. I also recommend you edit games profiles on your own now. Also make sure you are running on high priority for that system. As it will truncate the load. If you moved files repair them, Try not to do this as Activision Blizzard does not like it. I hope this helps.

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

          8 Replies
          • When you tried to launch the game, were you by any chance logged in to your account on your PC?

            Posting in language:

             

            Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

            5 Replies
            • Bamp

              Posting in language:

               

              Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

            • Anyone here who can help?

              Posting in language:

               

              Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

            • Edited by Alexander: 11/7/2017 11:25:33 PM
              I have the same issue same CPU and also an amd graphics card, on windows ten however.

              Posting in language:

               

              Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

              3 Replies
              • Any chance your AV / Security software is catching it?

                Posting in language:

                 

                Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                4 Replies
                • I will not be buying a second copy until this issue is resolved.

                  Posting in language:

                   

                  Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                You are not allowed to view this content.
                ;
                preload icon
                preload icon
                preload icon