JavaScript is required to use Bungie.net

Ayuda

Ayúdanos a ayudarte.
6/12/2024 8:51:36 PM
4

The final shape + annual dlc still not working for me

I have spent the last couple of days since the launch of the new dlc waiting to be able to play it. I bought the Final shape + annual pass, I was able to do the first mission but after that I wasn't able to do anything else related to the new campaign or anything. it shows in steam that I have purchased it and it shows in the eververse page that I have as well. I have tried reinstalling the game and making sure the dlc is fully downloaded and nothing has fixed it. I can't even refund the dlc due to play time on the game it's self so please find a way to fix this so I can actually enjoy the money spent on the new content and the time waiting for it to be fixed.

Publicando en idioma:

 

Pórtate bien. Echa un vistazo a nuestro Código de conducta antes de publicar tu mensaje. Cancelar Editar Crear escuadra Publicar

Ver el resto del tema
No se te permite acceder a este contenido.
;
preload icon
preload icon
preload icon