JavaScript is required to use Bungie.net

Ayuda

Ayúdanos a ayudarte.
Editado por Archaon217: 10/24/2019 5:21:57 AM
0

Dropped Emblem required for Dredgen title, but despite equipping it it's not appearing in collections as owned.

https://imgur.com/a/Rdrd5UT Basically as title says. I killed the taken meatball monstrosity, it dropped the emblem... but it didn't actually mark it as obtained in collections even though it's now in my inventory. I've tried equipping it and that does nothing. It still shines in the inventory as if it's "new" even while it's equipped. EDIT: I've now tried both relogging and storing it with F. Relogging did nothing and storing just deleted it, still cant reclaim it from Drifter or collections. Is there a way to have it readded back in via admin? I've looked at collections again after storing it, despite it showing as a recent drop I can't click on it. Right clicking to deal with the variants works but I cant click on anything in there, all the buttons just flash red. I do have one of it's' variants unlocked for whatever reason but I can't reclaim it, it just flashes red again when I try to.

Publicando en idioma:

 

Pórtate bien. Echa un vistazo a nuestro Código de conducta antes de publicar tu mensaje. Cancelar Editar Crear escuadra Publicar

No se te permite acceder a este contenido.
;
preload icon
preload icon
preload icon