JavaScript is required to use Bungie.net

Help

Help us help you.
Edited by Casterx: 1/4/2022 5:24:48 PM
1

After Reset the Forerunner Catalyst-quest is still bugged

Hey, to shorten it below what i did until now: - on the first week of 30th. ann. i got the weapon itself and the lvl 16 card (i dismantled the card to reset the quest didnt work ofc) - regained the key from xur (which had no purpose anymore cause ive the weapon) -got the first part of the quest from archive and went to xur. The quest disapeared but no progress. Quest archive is emtpy too. Now since a week ive just the cata on Xurs 2nd page saying need the finish of "Magnum Opus" which i finished (since ive the weapon lol) and even grabbed from archive but that didnt worked either. I tried to gain it with all three characters of mine. Im happy for any new suggesstions but more im happy about a fix!
English
#Help #gameplay

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

You are not allowed to view this content.
;
preload icon
preload icon
preload icon