JavaScript is required to use


Help us help you.
Edited by MortalityBytes: 11/22/2020 8:52:52 PM

"You have lost connection to the destiny 2 servers. Your permissions to access online multiplayer gameplay may have changed or your profile may be signed in elsewhere"

For most from what I've been reading this usually happens for people trying to sign in in general, but for me this is only happening when I try to join my friends fireteam. I can load into the tower by myself no problem. I tried everything all of the old posts of this topic suggested but nothing's worked. Only thing I didn't try was having a friend sign in onto my account and into the game from their end and signing out, but that doesn't seem like it would fix my issue. Anyone wanna help??? Please? I hope I put this in the right category. I recently switched to a LAN cable like a week ago but I changed all of the settings and everything already, and this just happened today on 11/22/2020 around like 2:15 pm central. I didn't have any issues this morning even until just now. EDIT: also no, my account isn't signed in anywhere else besides my phone here. I had the destiny 2 app installed and logged in on there but I logged out and uninstalled that thinking it would fix it too. EDIT 2: My friend can join my fireteam no problem, and if I promote him to fireteam leader it's still fine. So I don't get what's up with this issue????

Posting in language:


Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

View Entire Topic
You are not allowed to view this content.
preload icon
preload icon
preload icon