JavaScript is required to use Bungie.net

Help

Help us help you.
Edited by Myist: 10/12/2019 4:53:50 PM
4
15
Myist

FPS drops after moving to Steam

Been having problems since game moved to steam. Prior i had 0 problems on Battle.net and my fps was at stable 60 but now its gone. Every 'Vex Offensive" run is a slug because of my framerates dropping to 40's when all the players are blasting their abilities and weapons on a horde of enemies. Framerate drops on Titan, EDZ, and Mars even when nobody around. Even on all low settings and rendering put to 50% the same problem remains. I tried all the troubleshooting from BugieHelp, from Technical subreddit: Reinstalled drivers, rolled back drivers, reinstalled the game, tweaked nvidia control panel, deleted CVARS, played around with game's display window, updated windows, and much more minor fixes. Still, it changes literaly nothing. Tested the game trough HWiNFO64 and saw that my GPU and CPU are working at around 40-50% load. So im currently at a loss. Hoping that Bungie team will adress game performance after moving to steam sometime in the future Thanks for your time reading this. Some of the spec: CPU: Intel Core i7-3820 GPU: MSI GTX 1660 Ti 6gb SSD: Samsung 860 Evo 500Gb RAM: Kingston SyperX DDR3 16Gb
English
#Help #pcsupport

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

View Entire Topic
  • Hi! I was having a similar problem, I'm using a I3 7100 and a gfx1060, pretty "minimum requirements", but I kinda expected to be able to play it low quality/60fps... which was not what i got, much like you the framerate was very unstable, dropping to 30, it didn't matter if I put low or max settings and coreTemp showed the cpu working at 50%... I guess my machine was not at fault here. Searching around the web I found these two solutions which helped me: 1- With the game running, hit ctrl+alt+del, task manager, go to the details tab, find destiny.exe, right click, [b]set priority to High[/b]. In my case this increased the fps, not yet stable, but higher numbers. Problem is you have to do this each time you launch the game. 2- Before launching the game, on Steam, right click the game, properties, set launch options, put this "[b]-high -USEALLAVAILABLECORES[/b]" . Found this on some weird site, no mention of this anywhere else... but it worked! This stabilized the fps. I currently can run around the first open area on earth ( the one with the church ) and also Titan, at stable 60, with medium settings. Not exactly sure what the commands do, or if the game is really not running at high priority on windows... but these worked for me, hope it helps you or anyone that comes here looking.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    1 Reply
    You are not allowed to view this content.
    ;
    preload icon
    preload icon
    preload icon