JavaScript is required to use Bungie.net

Companion App

What needs work in the Companion App?
10/13/2019 4:49:38 PM
0

Please fix error Weasel

Its been 3 weeks now and i am getting this error all the time every 2 hours its is not funny any more i did everything the network trouble shot is asking and i am still getting the error. Please fix this
English
#companionapp

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

You are not allowed to view this content.
;
preload icon
preload icon
preload icon