JavaScript is required to use Bungie.net

Help

Help us help you.
10/9/2019 2:38:13 AM
2

Universal Ornament not appearing after purchase

I bought a leg universal ornament with bright dust and unlocked it in my inventory but it isn't appearing in my ornament tab for my leg armor. I relogged but still hasn't appeared. Did I mess up or am I just being dumb?
English
#Help #Eververse

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Anything bought with silver goes into your inventory Inca box similar to when someone uses an Eververse boon in the Crucible and you get a reward of a pack of shaders. You must open the box for the item to be equipped. If you don't open the box, you also have the option of refunding it within a week.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    1 Reply
    • Edited by DerQued: 10/9/2019 4:51:38 PM
      I am having this problem as well. I unlocked it and even relogged. Still nothing. Edit: I just discovered that New ornaments can only be put on gear that you receive after the latest patch and cannot be used on old gear... so i guess we gotta go out and farm some new gear man... :/ Edit: New ornaments can only be used on gear attained after the recent patch

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

      4 Replies
      You are not allowed to view this content.
      ;
      preload icon
      preload icon
      preload icon