JavaScript is required to use


Help us help you.
12/6/2018 10:31:48 PM

Tree of Probabilities (Curse of Osiris Mission) Bug

I had gone through the entirety of the mission without issues, and reached the final boss. He turned and charged me, and I pulled out my golden gun (with the Celestial Nighthawk equipped) and one shot him while he was charging. The rest of the enemies despawned. The mission told me to go to the thing at the end, and hack it, and as I moved through the final hallway, it said "Rejoining allies in 5 seconds" and counted down. Before I could reach the terminal, it sent back to the boss room. I tried again. And again. And Again. I tried dying. I tried entering the hallway slowly, quickly, entering then leaving before I was sent back, etc. I'm playing alone. I don't have any allies. There was just me. Doing a story mission. I've left the mission, and I'm going to retry it. I'll let you know if I run into the problem again. I am on PC.
#Help #gameplay

Posting in language:


Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

You are not allowed to view this content.
preload icon
preload icon
preload icon