JavaScript is required to use Bungie.net

Help

Help us help you.
12/25/2017 9:39:02 AM
9
14
MCQ
MCQ

Destiny 2 Long Loading Times and Micro Stutters

I'm running a Dell Inspiron 5675 that has Ryzen R7 1700 16GB DDR4 AMD RX580 When I start the game, the performance is great, but about 20 minutes later, the performance starts to decrease slightly, and my loading times jump from 20 seconds to 3 minutes for any travelling (e.g. Strikes, travelling between planets, etc.). Another weird occurrence after about 15 minutes from starting destiny, joining crucible matches causes very bad microstutters and sound stuttering for the first 20 seconds of a PvP match. I can't move or really do anything until it resolves itself The game is installed on an HDD, and I have not tried running the game on an SSD yet. I figure that would probably resolve the long loading times, but I don't know what the cause is for the Crucible match stutters. When I first start the game though, the loading times are very fast, and crucible matches don't have stuttering. What could be causing this? It also seems that the longer I play the game, the worse it gets overall, and I just have to restart the game to decrease my load times and crucible stuttering. I checked temperatures for the GPU and CPU and there was no sign of overheating, and I'm not sure if a memory leak is the issue, since my game plays well overall, despite the loading and small period of stuttering
English
#Help #pcsupport

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Ive had similar issues, except my game gets really slow in social spaces and loading times are long. I run a GTX 1050ti, core i5 7th gen, and have 1080p and I found that the problem is not my internet

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • This might help: https://www.reddit.com/r/Amd/comments/8cty1t/regarding_the_shader_cache_postadrenaline_17121/

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Bump

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • I was hoping this would have been fixed by the time this expansion came out... nope... still unplayable... I mean... I LOVE waiting 15-20 minutes between planet travel, or 10 minutes between mission loads... but this is ridiculous

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    2 Replies
    • I've been having the same problem with the rx 580. I rolled back to 17.11.1 like others but then I started having issues with crashing which is even worse than long load times. It seems the problem may be AMD settings so I used DDU to uninstall all the drivers and then reinstalled the newest drivers but I did custom install and unchecked AMD settings and so far it seems fine. Was curious if anyone else would have success trying this.

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    • I have had all the same problems with RX 480 8gb. I had the 17.12 drive and rolled back to the 17.11 and the load time were fine. Once the 18 patch came out I updated hoping it would you know..... work. Unfortunately its the exact same. Not only do you have 3-5 min load screens to travel ANYWERE but some times in the world you just get the stupid loading on screen and cant do anything. I have again rolled back to the 17.11 driver and this again fixed the load times however, I know seem to crash 2-3 a day for random reasons either during strikes or crucibles. If anyone has any better input on this please share cause this is killin me.

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    • Edited by Jerminator: 1/19/2018 6:17:28 AM
      Tried rolling back to 17.11.1 and it worked well for a while until my computer started constantly crashing over and over. It crashed for destiny 2, batman arkham knight, Nox android emulator and even non intensive games like minecraft! I got everything from a full on red screen to the blue screen with the sadface on it. Even completely froze once. I had to update back to 17.12.1 it was the only thing that has worked so far and even then i had issues (i got error 98 on amd catalyst software and had to completely reinstall the software). Its impossible to play this game with extremely long load times. I finally make it into a strike and my team is already at the boss. Please help bungie this is a big issues! Ryzen R7 1700x Gigabyte GA-AX370-Gaming 5 G Skill Flare X 8 gig 3200mbps x 2

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    • I am having all of these exact issues as well. I have not seen any Bungie response to anyone making this complaint it's frustrating.

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

      3 Replies
      • Edited by Sariss: 12/25/2017 1:16:23 PM
        I think this one is not a Bungie issue. I had this problem yesterday. It started with the last update of AMD graphic driver, adrenaline version. I reverted to 17.11.1. Everything is working fine now. I think Amd screwed their drivers... again... Have a nice day !

        Posting in language:

         

        Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        5 Replies
        You are not allowed to view this content.
        ;
        preload icon
        preload icon
        preload icon