JavaScript is required to use Bungie.net

Help

Help us help you.
Edited by HentaiBishop: 8/31/2017 9:54:06 AM
19

Destiny 2 FPS stutter/drop

Destiny 2 fps drops/stutter Ill be honest, I never had so much trouble trying to fix a game before. This morning i went and waited for the game to come out at 1PM EST, I was so happy it came out but when i opened the game, i noticed that i was dropping frames. The frames would go from 200 to 10 every half a second, making the game almost unplayable. I thought it was something that i had to change in the settings but it was not. I spent around 4 hours looking into this and finding nothing that would even stop the lagging or even make it better. So I thought it was my GPU (GTX 770), I spent an hour and drove all the way to my local Microcenter to get a 1060. got home plugged it in and updated the drivers ("Ready for Destiny 2" I guess not) and got back on just to find out that the frame drops and stutters are still there Please someone help me!!!!! Specs Operating System: Windows 7 Professional 64-bit rocessor: Intel(R) Core(TM) i5-7600K CPU @ 3.80GHz (4 CPUs), ~3.8GHz Memory: 16384MB RAM Available OS Memory: 16342MB RAM DirectX Version: DirectX 11 Card name: NVIDIA GeForce GTX 1060 6GB Manufacturer: NVIDIA Chip type: GeForce GTX 1060 6GB DAC type: Integrated RAMDAC Device Key: Enum\PCI\VEN_10DE&DEV_1C03&SUBSYS_85AB1043&REV_A1 Display Memory: 4095 MB Dedicated Memory: 3072 MB Shared Memory: 1023 MB Current Mode: 1920 x 1080 (32 bit) (144Hz) Monitor Name: Generic PnP Monitor Monitor Model: GN246HL Edit: Im not sure if i might have fixed it or not, I turned on my PC and I went on my folders and deleted some stuff (Skyrim mods folder and file editor for skyrim). Got on blizzard launcher to see if there was an update for hope. Nothing, I got on and notice i wasn't lagging anymore. Im pretty sure it might not be fixed or when I restart my PC it will go back to stuttering but if it doesn't I'll come back with an update.
English
#Help #pcsupport

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Edited by Leah: 12/31/2017 2:27:46 PM
    Just for reference, I'm having zero problems with in-game framerate, but the FMV's (pre-rendered cutscenes) are stuttering incredibly badly to the point where entire portions get lost with an abrupt transition to the in-game environment as they end. I've noticed in the past that people often get confused between identifying issues that are occurring in-game and then differentiating them from issues that are occurring in pre-rendered cutscenes or "FMV" as I prefer to call it since that's been the term of choice since 1991. Anyway, just wanted to be clear that the stuttering issues I'm seeing are not related to the in-game environment, but are occurring with the FMV portions. According to GameRant.com [Source URL](https://gamerant.com/destiny-2-fix-pc-stutter-lag/) ...this issue was supposed to have been fixed by now in general; however people neglected to differentiate between the two modes that are processed by the OS and computer hardware in completely different manners; thusly having left out probably one of the most important details for the developers and gaming communities alike. This issue occurred during my first run of the game and continues to occur ONLY with the FMV scenes. The issue with FMV's stuttering and skipping is quite consistent. I've started a separate topic that includes the link to this post here as well: [New Thread about FMV's stuttering and skipping](https://www.bungie.net/en/Forums/Post/241288443) In the meantime, if anyone else has seen the same issue with stuttering FMV, and has already solved it, I'm certainly open to suggestions; however please be sure to post them to the new thread instead of this older one, or both if you think anyone on this post will also benefit from any knowledge offered. Thanks. :) Happy New Year! SPECS: Gen4 Xeon | 256GB ECC, Registered, Buffered RAM | Dual 1200W Platinum Redundant PSU's with I2C | eVGA nVidia 1070GTX 8GB Video Card | Studio Grade THX - Dolby - DTS - Compliant E-Mu / Creative Sound Card branded as "E-Mu" (Commercial Grade, not found on Creative Website, Branded as "E-Mu") | Windows 10 Tested as Fully DirectX12 Compliant | ISP - 1G/b p/s Fiber | Drivers: Latest Available - Installed every 28 days. NOTE: 4k HDR , HDCP v2.2. Monitor; however resolution is set to HD1080P as constant default because of personal preference and limited 4k content availability. Game is set to run in HD1080P same as all other games I play on my home/office workstation. IMPORTANT NOTE: This post has been updated from its previous content to include the link to the new thread due to the issue with FMV being consistent.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • I saw in a reddit post that leaving your clan will fix this

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Try updating to Windows 10 version 1709 [url]https://www.reddit.com/r/destiny2/comments/78huwm/destiny_2_pc_fps_drops/[/url]

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Same problem here. Leaving clan does not help and i have tons of vram left. I really hope bungie acknowledge the problem and fixes it.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • Lots of people reporting this issue. Leaving your clan seems to fix the stuttering. https://www.reddit.com/r/destiny2/comments/78w5cx/psa_leaving_your_clan_completely_fixes_the/

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

  • I'm also experiencing this issue (yay, another me, too comment) - suffice to say, my machine is more than powerful enough for D2. I was playing the game fine until the Nvidia 388.0 driver hit and I installed it overnight. Loaded up the game yesterday, started getting terrible FPS drops, especially after fast traveling. I was running at 60fps solid at launch, now it hovers at 45-50, which makes me sick if I play more than a few minutes. Turning off Vsync launches the FPS into the 120s, but the screen tear makes me even sicker. lol Someone on reddit said updating to the new Windows version fixed his: https://www.reddit.com/r/destiny2/comments/78huwm/destiny_2_pc_fps_drops/ I'm still on build 1703 with nary an update to be seen. I'll see if updating to 1709 fixes the issue.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    2 Replies
    • Saying "I'm having the same issue" and posting your specs isn't going to solve it xD

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    • Edited by HEDRAT: 10/25/2017 5:29:29 PM
      yeah im having the exact same issue. im only getting about 20-30FPS whereas my friends last night were getting upto 120FPS. here is my spec. Intel i5-7600k @ 4.5 GHz Geforce GTX 1070 8GB 16gb RAM Kolink 700W 80+ Rated Power Supply Gigabyte Z270 Gaming K3 (socket 1151) ATX Motherboard 250GB Solid State Drive 1TB Seagate Hard Drive Microsoft Windows 10 64Bit couple things i tried out was obviously decreasing the res and screen settings. this brought it up to about 20-25FPS. the only time i noticed the FPS at 60 was when i went into my inventory pages etc. soon as i went back into the actual game it then went back down to 20-25FPS. also if i set the screen to either Fullscreen or widescreen i am unable to change the Vsync (only stays at 24FPS). However, if i change to bordered fullscreen i am able to change to either 30FPS or 60FPS. Unfortunately, it makes no difference. Im still getting only upto 20-25FPS. The only solution i was able to get was to change all my graphics settings to low, with the RES at full. With this im getting upto 30-35FPS. This is a abit of a joke tbh. Im running a rig that is perfect for Destiny and for it not to reach the desired FPS even with the graphics at its lowest is really poor. Im new to the PCMR so my knowledge of PC's is very basic. luckily i have some friends who can help me who have a hell of alot more XP than me in the PC division lol. But seriously there has to be a solution to this problem. I am glad however that im not the only one. although it suks that this has to happen to us all. Also i wanted to add, i cant seem to open the Nvidia Control Panel, keeps coming up with an error saying that the display settings are not available.I have tried updating my Graphics card, but says its up to date. I thought maybe there was something in there that could help resolve my issue.

      Posting in language:

       

      Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

      2 Replies
      • I'm also having fps issues, during beta I was running around 125-150 frames, now with teh full game release, i hardly get 35. GTX Titan 32 GB DDR4 Intel Core i7-4770 3.4 GHz

        Posting in language:

         

        Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        1 Reply
        • exact same issue here, have spent 4 hours trying various things. i7 3770, gtx980ti, 8gb ddr3 @1866 sadly i just wont be playing the game until it's patched or something.

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        • Same problem. I7 6700HQ GTX 970M 16GB RAM Windows 10

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        • Having same issue as well but instead of fps drop its inconsistent frame times, or stuttering which makes gameplay very unplayable. 1440p Highest, FXAA, SSAO off, DOF off, Motion blur off. Avg of 100fps then constantly dips to 0 fps. Specs i7 6700k @ 4.7ghz GTX 1070 32GB's RAM 3200mhz

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

        • 2
          I have something like this but not as bad and it does not hinder my game play, but I go from 144fps to 72fps every second which I found quite weird, though i'm not sure if that because I have CPU boost on for my i7 2600k which changes the frequency often (SpeedStep).

          Posting in language:

           

          Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

          1 Reply
          • I'm having the same problems are you guys I guess. GTX 1080TI I7 6700k 16GBs of DDR4. I play on highest and 1440p but still this FPS drop just made me leave a game.

            Posting in language:

             

            Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

          • Edited by stephofni: 8/30/2017 6:18:07 AM
            (creates account) thank god im not alone. this problem has made me feel extremely alone and it feels like this is the only other post going through this mess. i've been furiously doing everything i can possibly think of to fix this problem. my computer has no excuse to be stuttering unplayably in this game. might be important to note - i enabled the FPS overlay and the game doesn't seem to change what FPS it thinks it's running when things hitch (which happens about once a second for me). i5 4690k (3.5 GHz x 4) nVidia GTX 1070 (8GB) 12 GB RAM WIndows 7 Pro SP1 also outputting 144Hz 1080p THINGS I HAVE TRIED THAT DID NOTHING changed all video settings to lowest changed all video settings to highest rescaling down rescaling up Vsync off Vsycn on at 144, 72, 48, and 36 Fullscreen, Windowed, Windowed-full, Borderless Multiple resolutions clean re-install of the game-ready driver forced nVidia's control panel (not GeForce Experience, the other one) to accept the Destiny 2 app is a game (it didn't auto detect it) and override video settings from there Disabled antivirus completely Attempted to re-install Direct X (no such luck, computer insists it's fine and dxdiag shows no issue) ran the battle.net tool to make sure the game files aren't corrupt, nothing found THINGS I HAVE TRIED WITH ANY SUCCESS Played rocket league - everything still runs completely fine, no issues Played quake champions - everything still works completely fine, no issues Ran overwatch (to test b.net client)- I went to the practice range, didn't actually queue, but it was fine OTHER NOTES i enabled the FPS overlay and the game doesn't seem to change what FPS it thinks it's running when things hitch (which happens about once a second for me). the settings menu also displays the right amount of VRAM - i had heard from a buddy who had to convince his computer that it should be using the better graphics card for some reason, but mine is detecting the 1070 just fine. PLANS TO TRY (tomorrow because it's late here) reinstall the game, despite b.net being convinced that it has nothing to repair switch to my 60Hz second monitor and see if that runs differently at that point, and failing any kind of official announcement... never think about destiny 2 again, i guess EDIT: one more thing, i forgot to mention, when the game started initially it had me in some 2k resolution, i don't know why, the screen doesn't support it... but now that i want to switch it back to see if that works, it isn't an option anymore.

            Posting in language:

             

            Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

            9 Replies
            • Same problem here. My rig is a lot weaker than yours but I still drop from 60 to 15 FPS every 2 seconds. AMD FX-6300 (3.8) AMD R9 290 4GB 8GB RAM Win7 64 1440x900 60Hz

              Posting in language:

               

              Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

            • I've been getting this too, made a new topic about it at https://www.bungie.net/en/Forums/Post/230334120?sort=0&page=0 Uploaded a recorded video of the stutter happening every second, recorded the mouse pointer as this was easiest to see https://www.youtube.com/watch?v=EnJ6Fx36tZ0

              Posting in language:

               

              Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

              2 Replies
              • I have a similar system to you and had the same issue. I managed to stop the stuttering completely by turning off Malwarebytes. If you don't have Malwarebytes I would try completely closing any software that may be actively monitoring your computer. Hope it helps.

                Posting in language:

                 

                Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                1 Reply
                • see how much vram you have available in the top of the video settings. I am having an issue where it is only allowing me 128 mb of vram even though I have a 970 https://cdn.discordapp.com/attachments/332609278613651467/352266141306978305/VRAM.png

                  Posting in language:

                   

                  Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

                  2 Replies
                  You are not allowed to view this content.
                  ;
                  preload icon
                  preload icon
                  preload icon