JavaScript is required to use Bungie.net

Service Warning
We will be pushing a patch live tomorrow. Players will be required to log in to Destiny again after returning to the title screen to install the patch. You should not be removed from any activities you are currently in.

Gaming

Talk about games other than Destiny. We don't mind.

8/17/2014 11:55:01 PM
24

Am I alone in wanting a current gen Dragons Dogma?

So I'm going to put it out there....I thought Dragons Dogma was sick. Not really because of the story....and the fact that the pawns said the same blaming! Thing over and over was pretty annoying but the combat and the challenge is what got me to lvl 200...well it changed to the infinity symbol after 199. But I want a current Gen version

Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

preload icon
preload icon
preload icon
You are not allowed to view this content.