JavaScript is required to use


Discuss what we all have in common.

11/6/2012 12:44:37 PM

Does support HTML5?

I just curious, will the new website we keep hearing about supports the latest version of HTML 5? Also, I would like to ask the reason behind the using of HTML 5 if it not so discreet to share.

Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

preload icon
preload icon
preload icon
You are not allowed to view this content.