JavaScript is required to use Bungie.net

#Crimson

1/13/2012 2:19:50 PM
9

Crimson on iOS 4?

I'd really like to play Crimson on my iPod Touch but I can't because its needs iOS 5 but because my iPod is 3rd Generation it doesn't have the update for iOS 5. So What I want to know is; is there any chance of it being available for iOS 4? Does anyone else feel this way?
Add more answer options

Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • [quote][b]Posted by:[/b] ARBITOR 5 It is 3rd Generation, I bought it new in 2009 for christmas when the 3rd gens came out. There must be a problem with the iPod then. Thanks for your help anyway guys. [i]Share the love [b]<3[/b][/i][/quote] I got mine in 2010, the stores lied to you. You see, they sold you an iPod Touch 2G like they did to me. They are cosmetically the same, so unless you inspect closely by reading the factory serial ID at the bottom (Under the What ever you have GB Symbol) If it has a nukber 2 tossed in, it's a second gen.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • [quote][b]Posted by:[/b] xTRlGGER092x You must have an iPod Touch 2nd gen, which runs iOS 4.2.1 at the latest. [/quote] Thats me.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • Do you have iTunes 10.5? You need it to update devices to iOS 5.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • It is 3rd Generation, I bought it new in 2009 for christmas when the 3rd gens came out. There must be a problem with the iPod then. Thanks for your help anyway guys. [i]Share the love [b]<3[/b][/i]
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • [quote][b]Posted by:[/b] xTRlGGER092x Like I said before, your iPod must be a 2nd gen, not a 3rd.[/quote] Yeah, apple sure aint no Microsoft/Intel. People have been used to being able to run OS's for years. You can hook up Win95 through Win7 on a single piece of Intel/AMD kit without an issue ... but with Apple its all about pushing you to upgrade to the latest hardware. And funnier still is the way in which this actually works for them .... even as they are pushing people onto the latest kit they are announcing how the next new [& incompatible] version is about 6 months away.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • [quote][b]Posted by:[/b] ARBITOR 5 [quote][b]Posted by:[/b] xTRlGGER092x Crimson does work on iOS 4; the minimum requirement is iOS 4.3. Also, 3rd gen iPod Touches can run iOS 5. You must have an iPod Touch 2nd gen, which runs iOS 4.2.1 at the latest. But to answer question, it's pretty much impossible that older than iOS 4.3 support will ever happen; Apple is trying to push developers to require iOS 5, not to go back in time.[/quote] Mmm strange. iTunes says there is no update for my iPod, and when I try to download it, it says it needs at least iOS 5. How odd haha.[/quote] Like I said before, your iPod must be a 2nd gen, not a 3rd.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • [quote][b]Posted by:[/b] ARBITOR 5 [quote][b]Posted by:[/b] xTRlGGER092x But to answer question, it's pretty much impossible that older than iOS 4.3 support will ever happen; Apple is trying to push developers to require iOS 5, not to go back in time.[/quote] Mmm strange. iTunes says there is no update for my iPod, and when I try to download it, it says it needs at least iOS 5. How odd haha.[/quote] And apple would rather push you to buy a whole new device. Why promote the life of a zero cost item when they can get you to buy a whole new product ... does come with free iOS5 installed though - lol.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • [quote][b]Posted by:[/b] xTRlGGER092x Crimson does work on iOS 4; the minimum requirement is iOS 4.3. Also, 3rd gen iPod Touches can run iOS 5. You must have an iPod Touch 2nd gen, which runs iOS 4.2.1 at the latest. But to answer question, it's pretty much impossible that older than iOS 4.3 support will ever happen; Apple is trying to push developers to require iOS 5, not to go back in time.[/quote] Mmm strange. iTunes says there is no update for my iPod, and when I try to download it, it says it needs at least iOS 5. How odd haha.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

  • Crimson does work on iOS 4; the minimum requirement is iOS 4.3. Also, 3rd gen iPod Touches can run iOS 5. You must have an iPod Touch 2nd gen, which runs iOS 4.2.1 at the latest. But to answer question, it's pretty much impossible that older than iOS 4.3 support will ever happen; Apple is trying to push developers to require iOS 5, not to go back in time.
    Add more answer options

    Cancel Edit Create Fireteam Post Play nice. Take a minute to review our Code of Conduct before submitting your post.

preload icon
preload icon
preload icon
You are not allowed to view this content.