JavaScript is required to use Bungie.net

Raptorkid24

Raptorkid24

7/21/2014 9:00:30 PM
Anyone? Anyone at all? Well, seeing all the troubles PS people have installing, and my crappy internet connection, I problem won't be able to install it anyway. Bleeehhhhhhh
preload icon
preload icon
preload icon
You are not allowed to view this content.