JavaScript is required to use Bungie.net

Help

NEWNS

NEWNS

7/30/2014 6:55:10 PM
so when i try to get the app it says "your device is not compatible with this version" its probably because i have an old sony experia but im just checking if there is anything i could do (other then buying a new phone) to fix this. there are no updates available for my phone.
preload icon
preload icon
preload icon
You are not allowed to view this content.