JavaScript is required to use Bungie.net

pikelhaubee

pikelhaubee

11/30/2012 4:57:06 AM
well I guess Apple isnt going to release it even though OS X snow Leopard really needs the security updates that come with it. Safari 5.1.7 has over 100 vulnerabilities! I also would not mind the unified search bar or even a full screen mode IS THERE ANY HOPE?!! Also before you tell me to upgrade to Lion or Mountain Lion I have a MacBook Pro First generation intel core duo soo its only 32 bit :( soo i cannot boot lion or mountain lion. Also I have several power pc applications that require rosetta to run which is no longer supported in lion or mountain lion

Edit Preview Cancel

preload icon
preload icon
preload icon
You are not allowed to view this content.