JavaScript is required to use Bungie.net

Your mission in the Destiny Beta is complete. Your next adventure begins on September 9th, with the official launch of Destiny.
2014-07-28T01:35:48Z

All Topics

Achronos

Achronos

5/19/2011 2:54:15 AM
If you haven't tried it yet, run Firefox in Safe Mode. If that doesn't work, uninstall it (and every other version of Firefox). Then go to your installation folders and make sure they're deleted and don't have anything in them. Remove any local settings in your user folder too. Then, finally, go back and get a fresh download of the installer, and install to the default location, every option default, and don't import any of your old settings/bookmarks/addons. If that doesn't work, then there is probably something wrong with your computer. And, for the record, nobody forces people to update to FF4. Some versions of FF3.6 and earlier simply have a bug in them that breaks rendering on bungie.net every so often, and we don't know of a workaround. I also maintain that Chrome is weaksauce, and IE9 is fast and works very well (I think it is much better than FF4, for example, with the exception of the Firebug addon).
Post Preview Cancel
preload icon
preload icon
preload icon
You are not allowed to view this content.